Chevron pointing left

Questions

Cannot get Camera Module to work

Asked 
Active 
Viewed 5 times
0
I have just bought a Camera Module 2 and cannot get it to work on either a Pi 2 or a Pi 1 that I have tried. Picture of the connection is attached. I get this response:

pi@raspberrypi:~ $ vcgencmd get_camera
supported=1 detected=0, libcamera interfaces=0 pi@raspberrypi:~ $ raspistill -o omage.jpg
mmal: Cannot read camera info, keeping the defaults for OV5647
mmal: mmal_vc_component_create: failed to create component 'vc.ril.camera' (1:ENOMEM)
mmal: mmal_component_create_core: could not create component 'vc.ril.camera' (1)
mmal: Failed to create camera component
mmal: main: Failed to create camera component
mmal: Camera is not detected. Please check carefully the camera module is installed correctly
 
In the config tool I have tried with legacy camera support enabled and disabled.
 
I have a new install of the latest OS.
IMG_20220603_204352031[1].jpg 85.2 KB
asked June, 12, 2022
Timothy Nicholson

Know someone who can answer? Share a link to this question via email, Twitter, or Facebook.

Your Answer

Thanks for contributing an answer to Little Bird!

  • Please be sure to answer the question. Provide details and share your research!

But avoid:

  • Asking for help, clarification, or responding to other answers.
  • Making statements based on opinion; back them up with references or personal experience
© 2022 Little Bird Electronics Pty Ltd.
Made with ❤️ in SYD. All prices inc GST. ABN 15 634 521 449. We're 🐥 @lbhq on Twitter.