Chevron pointing left

Questions

Teensy 4.0 dead?

Asked 
Active 
Viewed 5 times
1
Hi Little Bird,

I bought a teensy 4.0 earlier this week. I soldered the teensy to a (rev D) audio shield , and used the USB passthrough mode to play audio through the teensy/audio board to line in of an amplifier.

This worked absolutely perfectly, until tonight, when I turned the whole lot back on again to play some more, and the teensy doesn't appear in device manager (as a teensy audio device)

Additionally, I can't program it (pressing button when prompted also does nothing), and the audio obviously doesn't work anymore. There was also an unpleasant high pitched whine coming through the speakers connected to the amp.

The 5V on the teensy shows 4.86V on my multimeter, but the 3.3V only shows 0.227V.

Any idea what might be wrong here? Is there any way the audio board can damage the teensy?

I've tried a number of different USB cables, and I also have a teensy 3.5 here that works with those cables without an issue.

As I've soldered the teensy to the audio board, I can't easily separate them.

The source code is absolutely trivial. I've been using VS Code and platformio to program it.

Thanks in advance for any assistance.

Regards

Liam O'Hagan
caffeineau@gmail.com
asked September, 26, 2021
Arthur O'Hagan

1 Answer

1
As I've soldered the teensy to the audio board, I can't easily separate them.

I suspect that your Teensy got fried whilst soldering.
answered October, 04, 2021
Marcus Schappi

Your Answer

Thanks for contributing an answer to Little Bird!

  • Please be sure to answer the question. Provide details and share your research!

But avoid:

  • Asking for help, clarification, or responding to other answers.
  • Making statements based on opinion; back them up with references or personal experience
© 2021 Little Bird Electronics Pty Ltd.
Made with ❤️ in SYD. All prices inc GST. ABN 15 634 521 449. We're 🐥 @lbhq on Twitter.